import Foundation
let pattern = #".{13,}?[ ]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This is a test. The app should break this string in substring on whitespaces after 13 characters"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)