// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".{13,}?[ ]").unwrap();
let string = "This is a test. The app should break this string in substring on whitespaces after 13 characters";
let substitution = "$0\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}