using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{13,}?[ ]";
string substitution = @"$0\n";
string input = @"This is a test. The app should break this string in substring on whitespaces after 13 characters";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}