package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.{13,}?[ ]`)
var str = `This is a test. The app should break this string in substring on whitespaces after 13 characters`
var substitution = "$0\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}