using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"embed\/([\w+\-+]+)[\""\?]";
string input = @"<iframe width=""560"" height=""315"" src=""//www.youtube.com/embed/0gugBiEkLwU?rel=0"" frameborder=""0"" allowfullscreen></iframe>
<iframe width=""910"" height=""500"" src=""https://www.youtube.com/embed/b8-dyNY-j_123-o0xM"" frameborder=""0"" allowfullscreen></iframe>
<iframe width=""910"" height=""500"" src=""https://www.youtube.com/embed/uMs_Rq4ideA"" frameborder=""0"" allowfullscreen></iframe>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}