use strict;
my $str = '<iframe width="560" height="315" src="//www.youtube.com/embed/0gugBiEkLwU?rel=0" frameborder="0" allowfullscreen></iframe>
<iframe width="910" height="500" src="https://www.youtube.com/embed/b8-dyNY-j_123-o0xM" frameborder="0" allowfullscreen></iframe>
<iframe width="910" height="500" src="https://www.youtube.com/embed/uMs_Rq4ideA" frameborder="0" allowfullscreen></iframe>
';
my $regex = qr/embed\/([\w+\-+]+)[\"\?]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}