re = /embed\/([\w+\-+]+)[\"\?]/
str = '<iframe width="560" height="315" src="//www.youtube.com/embed/0gugBiEkLwU?rel=0" frameborder="0" allowfullscreen></iframe>
<iframe width="910" height="500" src="https://www.youtube.com/embed/b8-dyNY-j_123-o0xM" frameborder="0" allowfullscreen></iframe>
<iframe width="910" height="500" src="https://www.youtube.com/embed/uMs_Rq4ideA" frameborder="0" allowfullscreen></iframe>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end