import Foundation
let pattern = #"embed\/([\w+\-+]+)[\"\?]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<iframe width="560" height="315" src="//www.youtube.com/embed/0gugBiEkLwU?rel=0" frameborder="0" allowfullscreen></iframe>
<iframe width="910" height="500" src="https://www.youtube.com/embed/b8-dyNY-j_123-o0xM" frameborder="0" allowfullscreen></iframe>
<iframe width="910" height="500" src="https://www.youtube.com/embed/uMs_Rq4ideA" frameborder="0" allowfullscreen></iframe>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)