import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "embed\\/([\\w+\\-+]+)[\\\"\\?]";
final String string = "<iframe width=\"560\" height=\"315\" src=\"//www.youtube.com/embed/0gugBiEkLwU?rel=0\" frameborder=\"0\" allowfullscreen></iframe>\n\n"
+ "<iframe width=\"910\" height=\"500\" src=\"https://www.youtube.com/embed/b8-dyNY-j_123-o0xM\" frameborder=\"0\" allowfullscreen></iframe>\n\n"
+ "<iframe width=\"910\" height=\"500\" src=\"https://www.youtube.com/embed/uMs_Rq4ideA\" frameborder=\"0\" allowfullscreen></iframe>\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}