const regex = /embed\/([\w+\-+]+)[\"\?]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('embed\\\/([\\w+\\-+]+)[\\"\\?]', 'g')
const str = `<iframe width="560" height="315" src="//www.youtube.com/embed/0gugBiEkLwU?rel=0" frameborder="0" allowfullscreen></iframe>
<iframe width="910" height="500" src="https://www.youtube.com/embed/b8-dyNY-j_123-o0xM" frameborder="0" allowfullscreen></iframe>
<iframe width="910" height="500" src="https://www.youtube.com/embed/uMs_Rq4ideA" frameborder="0" allowfullscreen></iframe>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}