#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Vlan(\d+).+?(\d+\.\d+\.\d+\.\d+)\s+(\d+\.\d+\.\d+\.\d+)"
Local $sString = "Vlan100 10.170.237.32 255.255.255.0 ones 1500 100 false disable" & @CRLF & _
"Vlan102 10.170.208.253 255.255.255.128 ones 1500 102 false disable" & @CRLF & _
"Vlan201 192.168.214.2 255.255.255.0 ones 1500 201 false disable" & @CRLF & _
"Vlan202 192.168.215.1 255.255.255.0 ones 1500 202 false disable" & @CRLF & _
"Vlan203 192.168.216.2 255.255.255.0 ones 1500 203 false disable"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")