const regex = new RegExp('Vlan(\\d+).+?(\\d+\\.\\d+\\.\\d+\\.\\d+)\\s+(\\d+\\.\\d+\\.\\d+\\.\\d+)', 'm')
const str = `Vlan100 10.170.237.32 255.255.255.0 ones 1500 100 false disable
Vlan102 10.170.208.253 255.255.255.128 ones 1500 102 false disable
Vlan201 192.168.214.2 255.255.255.0 ones 1500 201 false disable
Vlan202 192.168.215.1 255.255.255.0 ones 1500 202 false disable
Vlan203 192.168.216.2 255.255.255.0 ones 1500 203 false disable`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}