import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Vlan(\\d+).+?(\\d+\\.\\d+\\.\\d+\\.\\d+)\\s+(\\d+\\.\\d+\\.\\d+\\.\\d+)";
final String string = "Vlan100 10.170.237.32 255.255.255.0 ones 1500 100 false disable\n"
+ "Vlan102 10.170.208.253 255.255.255.128 ones 1500 102 false disable\n"
+ "Vlan201 192.168.214.2 255.255.255.0 ones 1500 201 false disable\n"
+ "Vlan202 192.168.215.1 255.255.255.0 ones 1500 202 false disable\n"
+ "Vlan203 192.168.216.2 255.255.255.0 ones 1500 203 false disable";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}