#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)4<\/TH>.+?ergosbyt.+?Balance">(.+?)<\/TD>"
Local $sString = "<TR class="n" id="row">" & @CRLF & _
" <TH id="NN">2</TH>" & @CRLF & _
" <TD id="Alias">rt</TD>" & @CRLF & _
" <TD id="Balance">-499.68</TD></TR>" & @CRLF & _
" <TR class="n" id="row">" & @CRLF & _
" <TH id="NN">3</TH>" & @CRLF & _
" <TD id="Alias">mts</TD>" & @CRLF & _
" <TD id="Balance">1.20</TD></TR>" & @CRLF & _
" <TR class="n" id="row">" & @CRLF & _
" <TH id="NN">4</TH>" & @CRLF & _
" <TD id="Alias">ergosbyt</TD>" & @CRLF & _
" <TD id="Balance">-1 230.66</TD></TR>" & @CRLF & _
" <TR class="n" id="row">" & @CRLF & _
" <TH id="NN">5</TH>" & @CRLF & _
" <TD id="Alias">qiwi</TD>" & @CRLF & _
" <TD " & @CRLF & _
"id="Balance">0.00</TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></BODY></HTML>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")