using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"4<\/TH>.+?ergosbyt.+?Balance"">(.+?)<\/TD>";
string input = @"<TR class=""n"" id=""row"">
<TH id=""NN"">2</TH>
<TD id=""Alias"">rt</TD>
<TD id=""Balance"">-499.68</TD></TR>
<TR class=""n"" id=""row"">
<TH id=""NN"">3</TH>
<TD id=""Alias"">mts</TD>
<TD id=""Balance"">1.20</TD></TR>
<TR class=""n"" id=""row"">
<TH id=""NN"">4</TH>
<TD id=""Alias"">ergosbyt</TD>
<TD id=""Balance"">-1 230.66</TD></TR>
<TR class=""n"" id=""row"">
<TH id=""NN"">5</TH>
<TD id=""Alias"">qiwi</TD>
<TD
id=""Balance"">0.00</TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></BODY></HTML>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}