import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "4<\\/TH>.+?ergosbyt.+?Balance\">(.+?)<\\/TD>";
final String string = "<TR class=\"n\" id=\"row\">\n"
+ " <TH id=\"NN\">2</TH>\n"
+ " <TD id=\"Alias\">rt</TD>\n"
+ " <TD id=\"Balance\">-499.68</TD></TR>\n"
+ " <TR class=\"n\" id=\"row\">\n"
+ " <TH id=\"NN\">3</TH>\n"
+ " <TD id=\"Alias\">mts</TD>\n"
+ " <TD id=\"Balance\">1.20</TD></TR>\n"
+ " <TR class=\"n\" id=\"row\">\n"
+ " <TH id=\"NN\">4</TH>\n"
+ " <TD id=\"Alias\">ergosbyt</TD>\n"
+ " <TD id=\"Balance\">-1 230.66</TD></TR>\n"
+ " <TR class=\"n\" id=\"row\">\n"
+ " <TH id=\"NN\">5</TH>\n"
+ " <TD id=\"Alias\">qiwi</TD>\n"
+ " <TD \n"
+ "id=\"Balance\">0.00</TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></BODY></HTML>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}