package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)4<\/TH>.+?ergosbyt.+?Balance">(.+?)<\/TD>`)
var str = `<TR class="n" id="row">
<TH id="NN">2</TH>
<TD id="Alias">rt</TD>
<TD id="Balance">-499.68</TD></TR>
<TR class="n" id="row">
<TH id="NN">3</TH>
<TD id="Alias">mts</TD>
<TD id="Balance">1.20</TD></TR>
<TR class="n" id="row">
<TH id="NN">4</TH>
<TD id="Alias">ergosbyt</TD>
<TD id="Balance">-1 230.66</TD></TR>
<TR class="n" id="row">
<TH id="NN">5</TH>
<TD id="Alias">qiwi</TD>
<TD
id="Balance">0.00</TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></BODY></HTML>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}