// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)4<\/TH>.+?ergosbyt.+?Balance">(.+?)<\/TD>"#).unwrap();
let string = "<TR class=\"n\" id=\"row\">
<TH id=\"NN\">2</TH>
<TD id=\"Alias\">rt</TD>
<TD id=\"Balance\">-499.68</TD></TR>
<TR class=\"n\" id=\"row\">
<TH id=\"NN\">3</TH>
<TD id=\"Alias\">mts</TD>
<TD id=\"Balance\">1.20</TD></TR>
<TR class=\"n\" id=\"row\">
<TH id=\"NN\">4</TH>
<TD id=\"Alias\">ergosbyt</TD>
<TD id=\"Balance\">-1 230.66</TD></TR>
<TR class=\"n\" id=\"row\">
<TH id=\"NN\">5</TH>
<TD id=\"Alias\">qiwi</TD>
<TD
id=\"Balance\">0.00</TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></BODY></HTML>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}