import re
regex = re.compile(r"4<\/TH>.+?ergosbyt.+?Balance\">(.+?)<\/TD>", flags=re.DOTALL)
test_str = ("<TR class=\"n\" id=\"row\">\n"
" <TH id=\"NN\">2</TH>\n"
" <TD id=\"Alias\">rt</TD>\n"
" <TD id=\"Balance\">-499.68</TD></TR>\n"
" <TR class=\"n\" id=\"row\">\n"
" <TH id=\"NN\">3</TH>\n"
" <TD id=\"Alias\">mts</TD>\n"
" <TD id=\"Balance\">1.20</TD></TR>\n"
" <TR class=\"n\" id=\"row\">\n"
" <TH id=\"NN\">4</TH>\n"
" <TD id=\"Alias\">ergosbyt</TD>\n"
" <TD id=\"Balance\">-1 230.66</TD></TR>\n"
" <TR class=\"n\" id=\"row\">\n"
" <TH id=\"NN\">5</TH>\n"
" <TD id=\"Alias\">qiwi</TD>\n"
" <TD \n"
"id=\"Balance\">0.00</TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></BODY></HTML>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")