$re = '/4<\/TH>.+?ergosbyt.+?Balance">(.+?)<\/TD>/s';
$str = '<TR class="n" id="row">
<TH id="NN">2</TH>
<TD id="Alias">rt</TD>
<TD id="Balance">-499.68</TD></TR>
<TR class="n" id="row">
<TH id="NN">3</TH>
<TD id="Alias">mts</TD>
<TD id="Balance">1.20</TD></TR>
<TR class="n" id="row">
<TH id="NN">4</TH>
<TD id="Alias">ergosbyt</TD>
<TD id="Balance">-1 230.66</TD></TR>
<TR class="n" id="row">
<TH id="NN">5</TH>
<TD id="Alias">qiwi</TD>
<TD
id="Balance">0.00</TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></BODY></HTML>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);