#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<meta[\s]+[^>]*?name[\s]?=[\s\"']description[\s"']+content[\s]?=[\s"]+(?<content>.*?)["]|content[\s]?=[\s']+(?<content>.*?)[']+.*?>"
Local $sString = "<title>Design Custom Drinkware | Deluxe.ca </title>" & @CRLF & _
"<meta name="description" content="Customize drinkware from thousands of cups, mugs, koozies, and water bottles from popular brands. Personalize with your logo, image, or message to create promotional gifts they'll love. "/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")