import re
regex = re.compile(r"<meta[\s]+[^>]*?name[\s]?=[\s\"']description[\s\"']+content[\s]?=[\s\"]+(?<content>.*?)[\"]|content[\s]?=[\s']+(?<content>.*?)[']+.*?>", flags=re.MULTILINE)
test_str = ("<title>Design Custom Drinkware | Deluxe.ca </title>\n"
"<meta name=\"description\" content=\"Customize drinkware from thousands of cups, mugs, koozies, and water bottles from popular brands. Personalize with your logo, image, or message to create promotional gifts they'll love. \"/>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")