$re = '/<meta[\s]+[^>]*?name[\s]?=[\s\"\']description[\s"\']+content[\s]?=[\s"]+(?<content>.*?)["]|content[\s]?=[\s\']+(?<content>.*?)[\']+.*?>/m';
$str = '<title>Design Custom Drinkware | Deluxe.ca </title>
<meta name="description" content="Customize drinkware from thousands of cups, mugs, koozies, and water bottles from popular brands. Personalize with your logo, image, or message to create promotional gifts they\'ll love. "/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);