use strict;
my $str = '<title>Design Custom Drinkware | Deluxe.ca </title>
<meta name="description" content="Customize drinkware from thousands of cups, mugs, koozies, and water bottles from popular brands. Personalize with your logo, image, or message to create promotional gifts they\'ll love. "/>';
my $regex = qr/<meta[\s]+[^>]*?name[\s]?=[\s\"']description[\s"']+content[\s]?=[\s"]+(?<content>.*?)["]|content[\s]?=[\s']+(?<content>.*?)[']+.*?>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}