package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<meta[\s]+[^>]*?name[\s]?=[\s\"']description[\s"']+content[\s]?=[\s"]+(?<content>.*?)["]|content[\s]?=[\s']+(?<content>.*?)[']+.*?>`)
var str = `<title>Design Custom Drinkware | Deluxe.ca </title>
<meta name="description" content="Customize drinkware from thousands of cups, mugs, koozies, and water bottles from popular brands. Personalize with your logo, image, or message to create promotional gifts they'll love. "/>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}