using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<meta[\s]+[^>]*?name[\s]?=[\s\""']description[\s""']+content[\s]?=[\s""]+(?<content>.*?)[""]|content[\s]?=[\s']+(?<content>.*?)[']+.*?>";
string input = @"<title>Design Custom Drinkware | Deluxe.ca </title>
<meta name=""description"" content=""Customize drinkware from thousands of cups, mugs, koozies, and water bottles from popular brands. Personalize with your logo, image, or message to create promotional gifts they'll love. ""/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}