const regex = /<meta[\s]+[^>]*?name[\s]?=[\s\"']description[\s"']+content[\s]?=[\s"]+(?<content>.*?)["]|content[\s]?=[\s']+(?<content>.*?)[']+.*?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<meta[\\s]+[^>]*?name[\\s]?=[\\s\\"\']description[\\s"\']+content[\\s]?=[\\s"]+(?<content>.*?)["]|content[\\s]?=[\\s\']+(?<content>.*?)[\']+.*?>', 'gm')
const str = `<title>Design Custom Drinkware | Deluxe.ca </title>
<meta name="description" content="Customize drinkware from thousands of cups, mugs, koozies, and water bottles from popular brands. Personalize with your logo, image, or message to create promotional gifts they'll love. "/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}