using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\.[^.\n]+$";
string input = @"Hello.jpg
(ok)
Goodbye.mp4
(ok)
Free.xlsx
(ok)
GettingStarted
(NO)
File.81723.domain.8080.pdf
(ok)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}