import re
regex = re.compile(r".*\.[^.\n]+$", flags=re.MULTILINE)
test_str = ("Hello.jpg\n"
" (ok)\n"
"Goodbye.mp4\n"
" (ok)\n"
"Free.xlsx\n"
" (ok)\n"
"GettingStarted\n"
" (NO)\n"
"File.81723.domain.8080.pdf\n"
" (ok)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")