import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\.[^.\\n]+$";
final String string = "Hello.jpg\n"
+ " (ok)\n"
+ "Goodbye.mp4\n"
+ " (ok)\n"
+ "Free.xlsx\n"
+ " (ok)\n"
+ "GettingStarted\n"
+ " (NO)\n"
+ "File.81723.domain.8080.pdf\n"
+ " (ok)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}