$re = '/.*\.[^.\n]+$/m';
$str = 'Hello.jpg
(ok)
Goodbye.mp4
(ok)
Free.xlsx
(ok)
GettingStarted
(NO)
File.81723.domain.8080.pdf
(ok)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);