re = /.*\.[^.\n]+$/m
str = 'Hello.jpg
(ok)
Goodbye.mp4
(ok)
Free.xlsx
(ok)
GettingStarted
(NO)
File.81723.domain.8080.pdf
(ok)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end