// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\.[^.\n]+$").unwrap();
let string = "Hello.jpg
(ok)
Goodbye.mp4
(ok)
Free.xlsx
(ok)
GettingStarted
(NO)
File.81723.domain.8080.pdf
(ok)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}