# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\p{L}\s\d\-_~,;:\[\]\(\).'])//g;t' <<< "File001-dynamicstringfromwhereverö€_12$/°^1!$|<>(){}[]`´0=ß?'#,./\̶├"