package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\p{L}\s\d\-_~,;:\[\]\(\).'])`)
var str = `File001-dynamicstringfromwhereverö€_12$/°^1!$|<>(){}[]\`´0=ß?'#,./\̶├`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}