const regex = /([^\p{L}\s\d\-_~,;:\[\]\(\).'])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\p{L}\\s\\d\\-_~,;:\\[\\]\\(\\).\'])', 'g')
const str = `File001-dynamicstringfromwhereverö€_12\$/°^1!\$|<>(){}[]\`´0=ß?'#,./\\̶├`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);