#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^\p{L}\s\d\-_~,;:\[\]\(\).'])"
Local $sString = "File001-dynamicstringfromwhereverö€_12$/°^1!$|<>(){}[]`´0=ß?'#,./\̶├"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)