use strict;
my $str = 'File001-dynamicstringfromwhereverö€_12$/°^1!$|<>(){}[]`´0=ß?\'#,./\\̶├';
my $regex = qr/([^\p{L}\s\d\-_~,;:\[\]\(\).'])/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";