import Foundation
let pattern = #"([^\p{L}\s\d\-_~,;:\[\]\(\).'])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"File001-dynamicstringfromwhereverö€_12$/°^1!$|<>(){}[]`´0=ß?'#,./\̶├"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)