$re = '/([^\p{L}\s\d\-_~,;:\[\]\(\).\'])/';
$str = 'File001-dynamicstringfromwhereverö€_12$/°^1!$|<>(){}[]`´0=ß?\'#,./\\̶├';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;