#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[[:lower:]][[:upper:]]|\B[[:upper:]][[:lower:]]"
Local $sString = "PleaseMatch this" & @CRLF & _
"And alsoThis" & @CRLF & _
"this ASWell" & @CRLF & _
"thisTOO" & @CRLF & _
"1Aa" & @CRLF & _
"A1Aa" & @CRLF & _
"a1Aa" & @CRLF & _
"a1A" & @CRLF & _
"Though NOT THIS" & @CRLF & _
"Nor This" & @CRLF & _
"Foo_Bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")