package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[[:lower:]][[:upper:]]|\B[[:upper:]][[:lower:]]`)
var str = `PleaseMatch this
And alsoThis
this ASWell
thisTOO
1Aa
A1Aa
a1Aa
a1A
Though NOT THIS
Nor This
Foo_Bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}