import re
regex = re.compile(r"[[:lower:]][[:upper:]]|\B[[:upper:]][[:lower:]]")
test_str = ("PleaseMatch this\n"
"And alsoThis\n"
"this ASWell\n"
"thisTOO\n"
"1Aa\n"
"A1Aa\n"
"a1Aa\n"
"a1A\n"
"Though NOT THIS\n"
"Nor This\n"
"Foo_Bar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")