import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[[:lower:]][[:upper:]]|\\B[[:upper:]][[:lower:]]";
final String string = "PleaseMatch this\n"
+ "And alsoThis\n"
+ "this ASWell\n"
+ "thisTOO\n"
+ "1Aa\n"
+ "A1Aa\n"
+ "a1Aa\n"
+ "a1A\n"
+ "Though NOT THIS\n"
+ "Nor This\n"
+ "Foo_Bar";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}