const regex = /[[:lower:]][[:upper:]]|\B[[:upper:]][[:lower:]]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[[:lower:]][[:upper:]]|\\B[[:upper:]][[:lower:]]', 'g')
const str = `PleaseMatch this
And alsoThis
this ASWell
thisTOO
1Aa
A1Aa
a1Aa
a1A
Though NOT THIS
Nor This
Foo_Bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}