#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)GET_DICTIONARY(.*\n){2}(.*MTS.*)"
Local $sString = "{ " & @CRLF & _
" "action": "Handler:GET_DICTIONARY"," & @CRLF & _
" "locale": "en"," & @CRLF & _
" "data": {"dictionary_type":"MTS"}" & @CRLF & _
"}" & @CRLF & _
"{ "action": "Handler:GET_DICTIONARY"," & @CRLF & _
" "locale": "en"," & @CRLF & _
" "data": {"dictionary_type":"MTS"}" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")