package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)GET_DICTIONARY(.*\n){2}(.*MTS.*)`)
var str = `{
"action": "Handler:GET_DICTIONARY",
"locale": "en",
"data": {"dictionary_type":"MTS"}
}
{ "action": "Handler:GET_DICTIONARY",
"locale": "en",
"data": {"dictionary_type":"MTS"}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}