// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)GET_DICTIONARY(.*\n){2}(.*MTS.*)").unwrap();
let string = "{
\"action\": \"Handler:GET_DICTIONARY\",
\"locale\": \"en\",
\"data\": {\"dictionary_type\":\"MTS\"}
}
{ \"action\": \"Handler:GET_DICTIONARY\",
\"locale\": \"en\",
\"data\": {\"dictionary_type\":\"MTS\"}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}