import re
regex = re.compile(r"GET_DICTIONARY(.*\n){2}(.*MTS.*)", flags=re.MULTILINE)
test_str = ("{ \n"
" \"action\": \"Handler:GET_DICTIONARY\",\n"
" \"locale\": \"en\",\n"
" \"data\": {\"dictionary_type\":\"MTS\"}\n"
"}\n"
"{ \"action\": \"Handler:GET_DICTIONARY\",\n"
" \"locale\": \"en\",\n"
" \"data\": {\"dictionary_type\":\"MTS\"}\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")