re = /GET_DICTIONARY(.*\n){2}(.*MTS.*)/m
str = '{
"action": "Handler:GET_DICTIONARY",
"locale": "en",
"data": {"dictionary_type":"MTS"}
}
{ "action": "Handler:GET_DICTIONARY",
"locale": "en",
"data": {"dictionary_type":"MTS"}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end